Project

General

Profile

Support #1501

xtreg and fixed effects

Added by Leilah Plant-Tchenguiz over 1 year ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Start date:
02/04/2021
% Done:

100%


Description

Hi,

I have been trying to estimate a panel regression using xtreg, fe in Stata. My observations are at the level of individuals for multiple waves. Since svy is not supported, how can I run the fixed effects estimation taking account of sample design? I have included pweight, but don't know how to account for clustering and strata. Would I end the xtreg command with "vce(cluster psu)"? Or should I use "vce(cluster pidp)"? Or one source I read suggested creating a new variable consisting of unique combinations of psu and strata (call it uniquevar) and then using "vce(cluster uniquevar)". I don't really understand the econometrics behind this, so any help would be appreciated.

Also available in: Atom PDF