Project

General

Profile

Support #993

merging birth month and birth year to idresp and youth surveys

Added by Yaroslava Zemlyanska over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Urgent
Category:
-
Start date:
07/05/2018
% Done:

100%


Description

Hello,

I am using the Harmonised BHP and Understanding Society dataset to evaluate the impact of raising the minimum legal age for purchase of e-cigarettes on smoking prevalence using regression discontinuity design. I have aggregated the US wave 2-7 datasets into one and reshaped them, however I am not able to merge it with the cross wave id dataset, which contains information on individual's month and year of birth. Without this information, I cannot carry out the analysis. If you could please help me I would really appreciate it! Thank you.

Please find below the description of what I did:

1. I merged waves 2-7 from responding adults 16+ dataset ("indresp") and reshaped it into long format
2. I merged waves 2-7 from youths (age 10-15) dataset and reshaped it into long format
3. I appended the 2 datasets together
4. I tried merging the cross wave id dataset ("xwaveid") with the combined long file as follows:

merge 1:1 pidp using "/Users/.../xwaveid.dta"

however that did not work out because pidp did not uniquely define observations in the long format. I then reshaped the combined file into wide format and repeated the above command to obtain 80'290 matches instead of the full 121'665 that are in xwaveid file. Could you please let me know what am I doing wrong and how can I assign the month and year of birth to all individuals from both youth and adult questionnaires?

Additionally, if my data is in long format, can I run regression discontinuity analysis as if I had cross-sectional data?

Thank you in advance. I look forward to your answer.

Kind regards,

Yaroslava

Also available in: Atom PDF