Project

General

Profile

Support #351

longitudinal vs. cross-sectional weights

Added by Carolina Zuccotti almost 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Weights
Start date:
03/19/2015
% Done:

100%


Description

Hello,

I have been doing analysis on the impact of parental employment (measured with the retrospective question) on individuals' labour market outcomes. So far, I have used Wave 3 only, and I have used the other waves to replace missing data in Wave 3, such as age, gender, ethnicity, parental information, etc. I have been using therefore a cross-sectional weight:

svyset c_psu [pweight = c_indinub_xw], strata (c_strata) singleunit(centered)

With this weight I have done all my descriptive tables and my regression models so far. Now, I would like to add to my regression models a variable that measures employment status of the individual in Wave 2, since I am planning to start looking at transitions into and out of employment. Also, I would like to make crosstabs with this variable as well. This means, I believe, that I need to start using longitudinal weights. But how do I do that?

1) Descriptive tables: Should all my tables use the longitudinal weight? Or should I use it only when I am studying, for example, employment status in two different waves? (i.e if I make a table that relates employment in Wave 3 with parental background, should this table also have a longitudinal weight, even if I am not studying transitions?)

2) Regression tables: Imagine that I make two regression models, where I estimate the probability of employment by age, gender and parental background; and a second one where I also add employment in t-1 as control variable. In the first model there are no changes over time, while in the second there are. Should I still use the longitudinal weight for both?

Of course, changing the svyset all the time does not seem like the logic solution here, so I assume I will just stick to one. I just want to understand the implications of using one or another weight.

Thanks in advance for your help!
Regards,

Carolina

Also available in: Atom PDF