Project

General

Profile

Support #252

Data on parents of children in c_child.dta

Added by Jose Iparraguirre over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Data analysis
Start date:
03/28/2014
% Done:

100%


Description

I'm working with the Wave 3 data (eventually, I'll look into the three waves but for the moment, I'm at a preliminary cross-sectional analysis stage).
I want to get some descriptive characteristics of the parents of the children in the c_child.dta dataset (say, their ages and employment status).
The problem is that when I merge c_child.dta with c_indresp I get no matched records. I was suggested to identify the pidp of the parents via the variable c_relationship_dv in the c_egoalt.dta dataset, which I did. But even merging this new dataset with c_indresp leaves me with no records.
Could anyone help me with this, please?
Many thanks,
José

PS: a simple code is:

use "XXX\c_child.dta", clear
sort c_hidp
merge 1:m c_hidp pidp "XXX\c_indresp.dta"

or,

use "XXX\c_egoalt.dta", clear
keep if ( c_relationship_dv>8 & c_relationship_dv<13)
save "XXX\red.dta", replace
sort c_hidp
merge 1:m c_hidp pidp "XXX\c_indresp.dta"

Also available in: Atom PDF