Project

General

Profile

Support #1558

Cross-sectional vs longitudinal weights

Added by Carolin Schmidt 4 months ago. Updated 4 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Start date:
06/28/2021
% Done:

100%


Description

Hello,

I am working with Understanding Society for the first time and have a few questions.

My coauthors and I are analysing immigrants’ age at immigration and their housing outcomes (own or rent). We’ll merge household data with individual (i.e. respondent) data so that we can use the person’s age at migration and other variables together with household data. My questions mainly refer to the weights that we should use.

Since we’re interested in an invariant variable (age at migration) we cannot use household fixed effects and would therefore run regressions in the pooled sample in our main regressions. We classify a household as an immigrant household if the respondent is an immigrant. If I’m not mistaken, that means that we should use cross-sectional (i.e. a_, b_, c_, …) household (i.e. hhden_) weights, is that correct? That is, I’ll have „a_hhden_“ for all cases in wave 1, „b_hhden_" in wave 2, etc. If we run robustness checks within age-at-migration subgroups, we can make use of the panel structure again. I suppose we should use the longitudinal weights then?

We are not only interested in immigrants from the five subgroups mentioned in Q4 of the FAQ help file, but also in immigrants from other countries. If, in the pooled sample, we first use data from wave 1 onwards and run additional checks using only data from wave 6 onwards, am I right that we’d have to use us_ weights (wave 1 onwards) and ui_ weights (wave 6 onwards), and that it would be wrong to use data from wave 1 onwards with us_weights and an „if wave >= 6" qualifier?

Thanks a lot in advance.

Best wishes,
Carolin


Files

Also available in: Atom PDF