Project

General

Profile

Support #1483

The use of weight "indscui_lw" reduces the number of observations. Is it correct?

Added by Jing Shen 11 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Start date:
01/16/2021
% Done:

100%


Description

Hello,

I’m currently doing some analysis about immigrants’ subjective well-being, so in my regression models, I used indscui_lw (combined UKHLS+BHPS+IEMB longitudinal adult self-completion interview weight) as the analytical weight. The comparison between weighted and non-weighted models shows that the use of the weight variable reduces the number of observations by almost 60%. As a result, non-significant coefficients in the non-weighted models would become significant in the weighted models. I just want to double check with you that if I have used the right weight variable and used it in a correct way. Thank you very much in advance.

#1

Updated by Alita Nandi 11 months ago

  • Status changed from New to In Progress
  • Assignee set to Olena Kaminska
  • % Done changed from 0 to 10

Many thanks for your enquiry. The Understanding Society team is looking into it and we will get back to you as soon as we can.

We aim to respond to simple queries within 48 hours and more complex issues within 7 working days. While we will aim to keep to this response times due to the current coronavirus (COVID-19) related situation it may take us longer to respond.

Best wishes,
Understanding Society User Support Team

#2

Updated by Olena Kaminska 10 months ago

Thank you for your question. You are using the correct weight if your model includes longitudinal information (i.e. any information form previous waves). If all of the information comes from one wave - use cross-sectional weight xw.
The longitudinal weight requires response in each wave since wave 6. If this is not required for your analysis you can create your own tailored weight starting with the issue weight _li at wave 6 and modelling nonresponse between wave 6 and your model.
Also, consider two other alternatives: using higher p-value (e.g. 0.1) if your sample size is very small. And consider using one-sided test if your have a prior directional hypothesis.

Hope this helps,
Olena

#3

Updated by Alita Nandi 10 months ago

  • Status changed from In Progress to Feedback
  • % Done changed from 10 to 80
#4

Updated by Alita Nandi 10 months ago

  • Private changed from Yes to No
#5

Updated by Understanding Society User Support Team 4 months ago

  • Assignee deleted (Olena Kaminska)
#6

Updated by Understanding Society User Support Team about 2 months ago

  • Status changed from Feedback to Resolved
  • % Done changed from 80 to 100

Also available in: Atom PDF