Project

General

Profile

Support #1241

Problem merging inderesp with children data

Added by Marina Fernandez Reino almost 3 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
High
Category:
Youth
Start date:
09/09/2019
% Done:

90%


Description

Hi,

My objective is to construct a dataset that includes all household members, including children aged 0 to 15. I want to examine certain youth outcomes in migrant families. In order to do that, I need to know the country of birth of the natural/adoptive/step mother and natural/adoptive/step father living in the same household as the child. Note that, in this case, I am just going to focus on the co-resident parent(s) regardless of whether they are the natural parents of the child. I am aware that one of the natural parents of child might not reside with the child.

I'm going to to detail the steps I followed so it is easier to understand the problem I have at the moment.

- Firstly I've merged the child and youth dataset. I saved all the variables of interest with capital letters except h_hidp and h_pno.
- Secondly, I’ve created couple-level variables in the indresp data file. These variables summarise the country of birth combinations of the partners within a couple, e.g. couples where both partners are UK born. I’ve also generated a variable identifying the country of birth of single adults.
- Thirdly, I’ve merged the new indresp dataset with the indall dataset.
- Fourthly, I’ve merged the resulting file from above with the children and youth dataset merged in step 1.

The resulting file includes all household members. I’ve generated a couple of variables to identify who is the responsible adult of children aged 0 to 15, so I know if the responsible adult is the mother other family member. The code reads as follows:

gen motherguardian=1 if (H_ADRESP15_DV==H_MNSPNO) & H_ADRESP15_DV!=. // Adoptive/Natural/Step mother is the responsible adult
gen fatherguardian=1 if (H_ADRESP15_DV==H_FNSPNO) & H_ADRESP15_DV!=. // Adoptive/Natural/Step father is the responsible adult
gen grandpguardian=1 if ((H_ADRESP15_DV==H_GRFPNO) | (H_ADRESP15_DV==H_GRMPNO)) & H_ADRESP15_DV!=. // Grandparent is the responsible adult
gen parentguardian=1 if motherguardian==1 | fatherguardian==1
label var parentguardian "Guardian is nat/step/adopt parent"

gen guardian=1 if motherguardian==1 | fatherguardian==1
replace guardian=2 if grandpguardian==1
replace guardian=4 if H_ADRESP15_DV==-8 | H_ADRESP15_DV==-9
replace guardian=3 if H_ADRESP15_DV>=1 & H_ADRESP15_DV<=12 & guardian==.
lab define guardian ///
1 "resp.adult is mother or father" ///
2 " resp.adult is grandparent" ///
3 " resp.adult who is not parent/grandparent" ///
4 " resp.adult missing", replace
lab val guardian guardian

Then I want to identify the country of birth of children’s responsible adults as well as their partners. I’ve already generated this variable in indresp, so I have this information. The problem I have is that there are some households with 2+ children where there is more than 1 responsible adult for those children. I’ve included below a fictitious example of such household (file attached). In this household there are 2 children (h_pno 4 and 5). Each children has different parents and hence different responsible adults. The mother of chidren 4 is UK born and her partner is also UK born. The mother of children 5 is Indian born and she is single.

I want to use a dataset only with children, but I need to have information about the country of birth of co-resdient parents and their couples in such dataset. The problem is that I don’t know how to attach the co-resident parents’ country of birth to each child when there are more than 1 responsible adults in the household (like in the example below) . This is mainly because the variable h_childpno in indresp is missing instead of indicating the pno of the child. This is actually surprising because I thought that h_childpno in indresp should take the value of the child the adult is responsible for.


Files

question for forum.docx (15 KB) question for forum.docx Marina Fernandez Reino, 09/09/2019 07:49 PM

Also available in: Atom PDF