Project

General

Profile

Support #1724

Weights and accounting for individual clustering

Added by Catherine Bunting 7 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Category:
Weights
Start date:
07/12/2022
% Done:

100%


Description

Hello,

I am carrying out logistic regression to estimate the association between transitioning from unemployment to employment and health service use. My sample contains all individuals who were unemployed at UKHLS W7. Transition to employment is captured using their employment status at W8 and health outcomes are measured at W9.

I have created an equivalent cohort using individuals who were unemployed at W6, and pooled the two cohorts to increase my sample size. I therefore have some clustering by pidp, as individuals contribute twice to the analysis if they were unemployed at both W6 and W7.

In Stata, I am using svyset to specify the psu, cross-sectional weight (indscui_xw) and the strata. How can I also account for clustering by pidp? Normally I would use logistic regression with option vce(cluster pidp), but this is not possible when using the svy:logistic command.

Thank you!
Catherine

#1

Updated by Olena Kaminska 7 months ago

Catherine,

You only need psu as your clustering variable as it is the highest level (pidps are nested within psu), and in a straightforward logistic regression only psu needs to be indicated.
But reading your analysis description, I wonder if you need longitudinal weights. If you are using w6 - w9 information make sure you use w9 lw weight.

Best,
Olena

#2

Updated by Catherine Bunting 7 months ago

Hi Olena - thanks so much for the speedy reply, that's very helpful.

Just to clarify - if I have a group of individuals and am using information about them from waves 7, 8 and 9, I should use the W9 longitudinal weight, not the W7 cross-sectional weight?

Thanks,

Catherine

#3

Updated by Annette Pasotti 7 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 90
#4

Updated by Catherine Bunting 7 months ago

Sorry Olena, one last question - if I use psu as the clustering variable, does that account for clustering by hidp as well as by pidp?

#5

Updated by Olena Kaminska 7 months ago

Kind of yes. The answer is more complicated because households are not a longitudinal concept, but I wouldn't worry about it.
Olena

#6

Updated by Olena Kaminska 7 months ago

And to reply to your earlier question, yes, use longitudinal weight from wave 9. As soon as you use information from 2 or more waves you need longitudinal weights.
Olena

#7

Updated by Catherine Bunting 7 months ago

Excellent, thanks very much for your help.

Catherine

#8

Updated by Understanding Society User Support Team 4 months ago

  • Status changed from Feedback to Resolved
  • % Done changed from 90 to 100
#9

Updated by Understanding Society User Support Team 2 months ago

  • Private changed from Yes to No

Also available in: Atom PDF